eterm

Adam Mercer ram at star.sr.bham.ac.uk
Fri Oct 19 19:13:03 PDT 2001


Ben wrote:

> The output from configure (for imlib2) is:
> 
> ...
> checking for XShapeCombineMask in -lXext... yes
> checking for TT_Init_FreeType in -lttf... yes
> checking for freetype.h... no
> checking for freetype/freetype.h... no
> checking for freetype.h... (cached) no
> checking for freetype/freetype.h... (cached) no
> 
> ERROR: freetype.h not found in freetype.h or freetype/freetype.h include
> paths. (ie /usr/include, /usr/local/include etc.). You need the freetype
> header files to build Imlib 2. This may mean you have to install the
> freetype-devel packages for your distribution or if all else fails
> find the source for freetype and install that somewhere where Imlib 2
> can find the header files.
> 
> You can obtain it from:
> ftp://ftp.enlightenment.org/pub/enlightenment/
> ftp://www.rasterman.com/pub/enlightenment/
> You can also obtain it from:
> http://www.freetype.org/
> You can obtain some truetype fonts from:
> http://voyager.cns.ohiou.edu/~sadkins/web_library/fonts/font_archive/
> 
> configure: error: Fatal Error: no FreeType header files detected.
> #
> 
> It just appears like it can't locate the freetype.h file, but as I said, it 
> is on the system in a few places.
> 
> I've tried passing the --x-includes parameter to the configure script, but 
> still no joy.
> 
> cheers,
> Ben


Are you sure it's freetype-1.3.1 you've got installed and not 
freetype-2.0.x?

Completly OT but I've noticed you've got a blueyonder.co.uk domain - 
cable modem?

Cheers

Adam




-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list