SSH trouble again

J.A. Neitzel jan.listbox at belvento.org
Fri Oct 19 10:26:14 PDT 2001


Adam Sutton wrote:
<snippetydoda />
>> > # You have no controlling tty.  Cannot read passphrase.
>>
>> I guess this is as root (#)? Maybe if you `tty'; then `ls' whatever
>> it says (for example):
>>
>> $ ls -l $(tty)
>> crw--w----    1 jan      tty      136,   0 Oct 19 10:41 /dev/pts/0
>>
> 
> I get the same thing, with adam instead of jan of course :)
> 
<snippetydoda />
> 
> I am using devpts
> 
> I have tried using a VT, exactly the same problem :(
> 
> It's really annoying, I know this is likely to turn out to be something
> really stupid,

I'd say! I'd be annoyed too...
Maybe "obscure" is a better term than "stupid" ;o)

> Any other ideas ?

Pulling at strings here... But, did you ever UNSUID your ssh bin so
that you have it as -rwx--x--x, -rwxr-xr-x, or some such???

If "no controlling tty" is still the error you see,
check the permissions on /dev/tty . See `man 4 tty' for more info, but
it is important for a number of reasons that this device file be set
to mode 0666 .

Did you reinstall ssh after that first problem?

> I can use the various clients ssh, scp etc... fine as root but when I
> attempt to use them as a normal user I get the following message
>
> # ssh -l someone somewhere
> Permission denied, please try again.
> Permission denied, please try again.
> Permission denied (publickey,password).

Did you get around this error? Is this new ssh trouble related in any
possible way?

I assume this original problem got fixed unless you were to say
otherwise. I also assume that there has been a time when everything
worked correctly wrt your ssh setup. Are these assumptions correct?
Or *not* correct?
-- 
Jeff

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list