SSH trouble again

Adam Sutton adam at adamsutton.co.uk
Fri Oct 19 10:01:42 PDT 2001


[snip]

> Now to the important thing, your problem..? I can't say that this
> will help, but it is something to check anyway. About the tty you
> wrote:
>
> > The debug message I get which seems to be the most important is
> >
> > # You have no controlling tty.  Cannot read passphrase.
>
> I guess this is as root (#)? Maybe if you `tty'; then `ls' whatever
> it says (for example):
>
> $ ls -l $(tty)
> crw--w----    1 jan      tty      136,   0 Oct 19 10:41 /dev/pts/0
>

I get the same thing, with adam instead of jan of course :)

> This is what I get from my current tty. What do you get? Are you using
> devpts, devfs, or something? Do you get the same error from a regular
> tty (e.g. /dev/tty[1-6])? Switch to a vt if you aren't already and try
> from there.

I am using devpts

I have tried using a VT, exactly the same problem :(

It's really annoying, I know this is likely to turn out to be something
really stupid, but it is really annoying not being able to ssh out from the
machine


Any other ideas ?

I really don't want to resort to using a precompiled binary, as that kinda
defeats the object of this whole excercise, ie to learn more about linux.

Thanks

Adam


-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list