SSH trouble again

J.A. Neitzel jan.listbox at belvento.org
Fri Oct 19 08:51:49 PDT 2001


Adam Sutton wrote:

> Read permission are set, that was just a typo, sorry, I have to admit I am
> using a windows box at the moment as I haven't installed a mail client on my
> linux box yet.
> 
> Not too sure why ssh would need to be readable though ?? I don't know of any
> other binaries which need to be readable to be executed, but am still
> relatively new to linux so I am happy to stand corrected

Howdy =)
You are right that this is not related to whatever is the problem.
Having the ssh binary set to mode 4711 (rws--x--x) is fine. IIRC,
when you install OpenSSH there is a configure option "--nosuid" or
something like that. If you don't use that option, then the ssh
binary intalls with its mode set as you wrote, 4711 (rws--x--x).

FWIW, ssh does not need to be setsuid root. At least, I don't know
when/where/why it would be necessary.

> Still no luck by the way, and if I was going to be quite frank, I wouldn't
> be so cocky, especially when your answer is no solution, one of the things
> people like about using linux is the community feeling, but replies like
> that are more likely to put people off.

I would agree.

> I know I am not as experienced as some people with Linux, and I am bound to
> ask what will sometimes appear stupid question,

Frankly, who is really to say what is a stupid question and what
is not? A question is a question is a question... =)

> but I have decided that
> bulding a complete LFS system will at least allow me to get a better idea of
> certain aspects.

I also would agree with this.

Now to the important thing, your problem..? I can't say that this
will help, but it is something to check anyway. About the tty you
wrote:

> The debug message I get which seems to be the most important is
>
> # You have no controlling tty.  Cannot read passphrase.

I guess this is as root (#)? Maybe if you `tty'; then `ls' whatever
it says (for example):

$ ls -l $(tty)
crw--w----    1 jan      tty      136,   0 Oct 19 10:41 /dev/pts/0

This is what I get from my current tty. What do you get? Are you using
devpts, devfs, or something? Do you get the same error from a regular
tty (e.g. /dev/tty[1-6])? Switch to a vt if you aren't already and try
from there.
-- 
Jeff

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list