glxinfo not compiling with gcc 3.0.1

Kusli kusli at rocketmail.com
Fri Oct 19 02:10:20 PDT 2001


Hi all

Just recently I build xfree again with gcc 3.0.1 and came across a problem
I've read some times before: glxinfo not compiling!

(was Re: GCC-3.0.1)
----- Original Message -----
From: "jerry" <jdinardo at ix.netcom.com>
To: <blfs-support at linuxfromscratch.org>
Sent: Tuesday, October 02, 2001 1:58 PM
Subject: Re: GCC-3.0.1
> The strangest thing I have found is the situation with X4.1.
> After I do  the normal make world /install, I have to change gcc to g++
> and remake directory and then make install again. I believe this was in
> the glxinfo (glx something or other) dir.
> It would not work if I changed gcc to g++ before the first make world.
> When this worked for me , I did
> not look any farther for a rational explanation, but I am sure there
> is a proper fix. I will probably look for it myself it I get some time.

After hacking around with a friend I figured, that libGLU.so is broken, it
doesn't link to libGL nor libX11. Looking at the command lines during
compilation of libGLU I couldn't belive what I saw: there was just a -ld
switch (meaning link to libd.so) but no other library. I added a few
switches (-lX11 -lGL -lXext ... probably some others), compiled again and it
worked! My libGLU.so doesn't have no unresolved symbols anymore...
Unfortunately it installed in --prefux=/usr and messed my system up... At
the moment I'm reinstalling a LFS 3.0, not having time to hack arount with
xfree again, sorry.


_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list