building GCONF (gnome)

Marco Rinck marco at romulus23.de
Thu Oct 18 12:09:28 PDT 2001


* Jason Gurtz <jason at tommyk.com> [011018 20:50]:
> > > [...]  Do you indeed have a "libxml.so"
> > romulus at venus:~$ ldconfig -v|grep libxml
> >         libxml.so.1 -> libxml.so.1.8.16
> >         libxml2.so.2 -> libxml2.so.2.4.5
> > root at venus:/usr/lib$ ls -l libxml.so
> > lrwxrwxrwx    1 root     root           16 18. Okt 17:02 libxml.so ->
> > libxml.so.1.8.16
> > configure: error: You need at least libxml 1.8.8 for this version of
> > gnome-print
> the 1.8.16 might be confux0ring it.  Maybe try making a (hard?)link:
> libxml.so.1.8.8 -> libxml.so.1.8.16

No this didn't help either. 

But as I was writing this email that I still thought that gnome-config
is the problem I thought to "strace" gnome-config to see what it does. 
And ... aha! ... it only looked for the libraries in /opt/GNOME/lib.

As I linked the libraries from /usr/lib/ to /opt/GNOME/lib ... it was
working! 

Its a little bit strange behaviour I think and I don't know whats the
cause but now both packages are compiling.


-- 
Ciao,
Marco

-= http://www.romulus23.de =-
-= http://www.medien-in-deutschland.de =-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list