kernel -2.4.10/11 and vfat

Adam Ottley aottley at home.com
Thu Oct 11 11:04:36 PDT 2001


On October 11, 2001 10:46 am, you wrote:
> what is wrong with vfat in these kernels?I've tried them both and for some
> reason every file on my vfat partitons is now an executable.Doesn't matter
> what extention it has (i.e  .txt, .png etc,etc) This didn't happen with
> 2.4.9 or any other 2.4.x version.I have compiled with my old 2.4.9 kernel
> config and without (starting from scratch)but still get the same darn
> results.Anyone have a clue what I can do about it?I do a lot of downloading
> in windows because there is no download client quit like getright for linux
> yet.Running chmod on multiple files can get to be a pain after a while.Can
> someone please help?
>
> thanks

Try mounting your vfat partition with the option noexec.  (mount -t vfat -o 
noexec <device> <mount point>)  Since vfat doesn't have permissions bits, the 
vfat driver makes everything executable if mounted with the exec option.

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list