Creating new user

Rolandas Imbrasas rolandas_i at centras.lt
Thu Oct 11 06:30:12 PDT 2001


"J.A. Neitzel" <jan.listbox at belvento.org> wrote in message
news:9q453n$vhg$1 at shadowfax.linuxfromscratch.org...
> Rolandas Imbrasas wrote:
> > "Gerard Beekmans" <gerard at linuxfromscratch.org> wrote in message
> > news:20011010105934.J23212 at gwaihir.linuxfromscratch.org...
> >> On Wed, Oct 10, 2001 at 09:34:19PM +1000, Rolandas Imbrasas wrote:
> >> > Why prompt shows 'I have no name!', '13' instead of 'admin' and where
it
> >> > gets '1000' from? I do not have such group?
> >> > I did apply shadowpasswd_plus hint earlier today but I do not think
it
> > could
> >> > be related.
> >>
> >> Have a look at the /lib directory and make sure the directory has mode
755
> >> and all the files in there as well (at least all the *.so files)
> >>
> > The /lib directory and all files in it have mode 755. I used chmod -c
755
> > but it changed nothing. :(
> > I checked /usr/lib as well.
> > I have no idea why it is doing this to me :(
> > Maybe I have to rebuild some package(s)? Just which one(s)?
> > Any ideas?
>
> Here are some possibilities...
> Have you check the modes of /etc and these files?
>
> /etc         mode = 0755
> /etc/passwd  mode = 0644
> /etc/group   mode = 0644
Well, I checked modes and found that /etc/passwd had 600 mode (I have no
idea how it happend). I changed to 644 and now everything is OK.

THANKS A LOT! :)

> I saw this in your message:
> drwxr-xr-x    4 1000     root         1024 Oct 10 20:24 ..
>
> Perhaps you should check who owns /home . 1000 is not root, or it
> probably shouldn't be. I would recommend `chown root /home'. Then
> do a `cat /etc/passwd' and `cat /etc/group' just to be certain they
> contain what you think they should contain.
>
> BTW, who is user 1000 ?
I created a user 'admin' before using 'useradd -g admin admin'. Because in
my login.defs a UID_MIN was 1000 (I changed it to 100 now) my admin got uid
1000 assigned to it by default. Possible that instead of 'chown admin
/home/admin' I put 'chown admin /home'.
Anyway, right now everything came back in the place :)

Thanks again!

Regards,
=-=-= Rolandas =-=-=




-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list