libgtop: ld unable to find 'atexit'

Marco Rinck marco at romulus23.de
Sun Oct 7 08:36:23 PDT 2001


* J.A. Neitzel <jan.listbox at belvento.org> [011007 17:15]:
> André Wyrwa wrote:
> > I'm trying to compile gnome and so libgtop, and it breaks, saying, ld couldn't
> > find 'atexit' in /usr/lib/libz.so.1.
> > 
> > Any ideas, hints, suggestions, answers ;-)?
> 
> Well, here is one ;o) Problem might be related to the optimization. My
> suggestion would be, first of all, to simply `unset CFLAGS CXXFLAGS' when
> compiling gcc, glibc, and probably everything else too...
> 
> BUT! IIRC, errors related to "atexit" have been mentioned elsewhere in regards
> to other things... Maybe it was with fileutils??? Any chance you are using an
> AMD Athlon/Duron CPU? I think the fileutils problem, ?_if_? it's even related,
> was more evident on Athlons.

No this is a problem with gcc 2.95.3 and glibc 2.2.3. I had this too
with my LFS 3.0pre4. There is a patch wich should solve the problem
but I had these problems also, even with the patch the same problem
was there. After some fiddling with glibc 2.2.4 the problem with
"atexit" was
solved, but now I had problems because of the changed glibc. I have
reinstalled my LFS.

I think the easiest solution for Andre is a new installation of LFS
3.0, with glibc 2.2.4 and gcc2.95.3 this problem is solved.


-- 
Ciao,
Marco

-= http://www.romulus23.de =-
-= http://www.medien-in-deutschland.de =-
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list