Cups mystery

ivo ivo at thecourtofeden.org
Fri Oct 5 07:07:07 PDT 2001


Hi,

I once had a working Cups (Printing System)
And than one day it stopped printing PDF's

This is the error log:

I [04/Oct/2001:16:35:47 +0100] Job 12 queued on 'hp' by 'ivo'.
I [04/Oct/2001:16:35:47 +0100] Started filter /usr/lib/cups/filter/pdftops (PID 325) for job 12.
I [04/Oct/2001:16:35:47 +0100] Started filter /usr/lib/cups/filter/pstops (PID 326) for job 12.
I [04/Oct/2001:16:35:47 +0100] Started filter /usr/lib/cups/filter/pstoraster (PID 327) for job 12.
I [04/Oct/2001:16:35:47 +0100] Started filter /usr/lib/cups/filter/rastertohp (PID 328) for job 12.
I [04/Oct/2001:16:35:47 +0100] Started backend /usr/lib/cups/backend/parallel (PID 329) for job 12.
E [04/Oct/2001:16:35:48 +0100] PID 327 stopped with status 1!
E [04/Oct/2001:16:35:48 +0100] No pages found!
E [04/Oct/2001:16:35:48 +0100] PID 328 stopped with status 1!

It goes wrong in pstoraster.

Well i recompiled cups, upgraded ghostview to gs 7.00
As Per Printing on LFS using CUPS Hint
Nothing worked. (The hint is good BTW)

So after that i wanted to play smart,
i untared my last working backup on hda5 and
chrooted into it.

Theoreticly I am back in time the way it was working !
It gave the exact same error !
The tests where with a pdf i once could print,
I check the bios for ECP setting.
What could be changed over time for the altert
behavoure, even when the software is the same as
when it worked.
Oke most pdf's will print when i manualy do like:

pdf2ps -> ps2ps -> lpr example.ps

Oh i work with a HP OfficeJet Pro 1150C
and the hpoj tools, which make devices like:

~# lpstat -v
device for hp: parallel:/dev/ptal-printd/mlc_par_0

With it i can use the scanner under linux

~# ptal-devid mlc:par:0
VSTATUS:$H00000000$M00000000,ff,DN,IDLE;MFG:HEWLETT-PACKARD;MDL:OFFICEJET
PRO 1150C;CMD:PCL,MLC,PML,PJL;CLS:PRINTER;DES:Hewlett-Packard OfficeJet
Pro 1150C;

I am freaking out on the tought it once worked.
What could be the problem ??

Thanks in Advance

Greetz Ovis

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list