still having problems with apsfilter SETUP

Scott Haugaard dino at coprolite.com
Wed Oct 3 09:20:50 PDT 2001


On Sunday 30 September 2001 10:13 am, Scott Haugaard wrote:
> On Friday 28 September 2001 06:00 pm, you wrote:
> > This works fine on my old Red Hat 7.1 system.  It also works fine if I
> > chroot to the old Red Hat root filesystem.
> >
> > If I run the current version of SETUP in the apsfilter package
> > (apsfilter-6.1.1), it kicks me out immediately.  If I enter the line from
> > SETUP:
> > echo $n "Accept license [Y|y|J|j|N|n] ? $c"; read answer
> > at a bash prompt, it will ask me for an answer. as it should.  If I echo
> > $answer right after the line in the script, it returns nothing, but if I
> > add text it will echo just the text, so it is getting to the above line
> > in the script, but it isn't reading in from the keyboard. If I try and
> > read right before the do_copyright(), it works.  If I try to read after
> > the { in the function, it doesn't work.  Any ideas?
>
> I never was able to figure out what this was, but I redid my LFS system
> from scratch and now it works.

It broke again, I believe, after I installed Ghostscript 7.02.  It worked 
again after I went back down to Ghostscript 6.51.  I think the script barfs 
on Ghostscript 7.02 for some reason.  I do notice that the script doesn't 
test for the later versions.  Anyway, if there are any of you following the 
print/printing hint and using gs 7.02 and apsfilter-6.1.1, I bet you will run 
into the same problem.  I like the ifhp filter and lprngtool better anyway.
-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list