Making LFS bootable

Lalit Agarwal agarwallalit at hotmail.com
Mon Oct 1 14:26:01 PDT 2001


Well, I got it to boot finally. Thanks for all your input guys. Although I
was getting the same errors even after following all the leads. The way it
worked is, I tried was using a floppy to boot the hdb (now hda). However,
creating a floppy to boot my LFS was a bit pain. I had to copy the files
/sbin/mkbootdisk, /sbin/mkdosfs, /sbin/syslinux and /usr/bin/initrd ( I am
not so sure about the last file) from my redhat to LFS and then it worked in
the chrooted environment. Also I think I had to rename my lfskernel to
vmlinuz-2.4.8. This floppy helped me to boot into my lfs HD (Redhat HD
unhooked). Once into LFS I made the correct changes into the lilo.conf and
ran lilo. Rebooted and voila it boots directly from my LFS HD. Now my
question was it the lack of files /sbin/syslinux, /usr/bin/initrd (not sure
??) causing my earlier woes or was it renaming the kernel (I don't think
this one is the reason)? I know it might sound a bit stupid the way I got
this to work but since I got it to work is all that matters. Now my main
problem, I built this on a PIII 500Mhz machine. I have to use this in a 386
40Mhz machine. I did make sure at "make menuconfig" while compiling the
kernel that it should work for a 386. I hooked it up to that and it came
good till the LILO prompt and it starts to load lfs but after 5 seconds it
automatically reboots. Now, I read somewhere that it may not be possible to
use the LFS created on one machine on another. Is there a way out of this
situation for me????

Thanks again for all your inputs.

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list