Hostname not found

J.A. Neitzel jan.listbox at belvento.org
Mon Oct 1 09:13:14 PDT 2001


Jan Stifter wrote:
> hello,
> whenever I start X, the system prints "Hostname lookup error" or
> something like this (I am writing this from my brain).
> 
> My .xinitrc has only one line (startkde). This problem also occurs
> with blackbox, so I assume, it is X related and not windowmanager
> related.

I know others have responded to this already, but if you still have
problem there is one thing that is really easy to overlook. I had
this problem once, and finally tracked it down. I mostly ignored the
error a first because everything worked except for `hostname -f'.

If you type in `hostname -f' and still get this error, check the
permissions of your /etc/nsswitch.conf . Is it less than 0644 ?

Here are the notes I made when I finally figured out what caused
this weird problem.
#@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@#
# don't use this one until i figure out what's with the hostname prog #
# found hostname problem:                                             #
#     /etc/nsswitch.conf needs to be mode 0644                        #
#     it, ^^^^^^^^^^^^^^, was set to mode 0640                        #
#     result = normal, unprivileged, users got an error               #
#              when running `hostname -f'                             #
#     FIXED on Sat Aug 18 10:02:15 EST 2001                           #
#@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@#
-- 
Jeff

-- 
Unsubscribe: send email to listar at linuxfromscratch.org
and put 'unsubscribe blfs-support' in the subject header of the message



More information about the blfs-support mailing list