gnome-libs compile error

Mike Hildebrandt mikehild at insight.org
Tue Nov 28 08:29:07 PST 2000


Looks like the updated hint I posted a few weeks back never made it onto the
website, so I've reattached it here (Gerald, could you replace the old hint
with this one?  Thanks!).

To answer your question, just add the option --enable-compat185 to
../configure and recompile it.


> -----Original Message-----
> From: lfs-apps-owner at linuxfromscratch.org
> [mailto:lfs-apps-owner at linuxfromscratch.org]On Behalf Of
> Arnout Couperus
> Sent: Tuesday, November 28, 2000 12:22 AM
> To: lfs-apps at linuxfromscratch.org
> Subject: gnome-libs compile error
>
>
> I'm now installing gnome according to the gnome-install LFS-Hint,
> but I think either something might have changed between
> gnome-libs version 1.2.3 and 1.2.8 or it's my system, but I
> keep getting the following error:
>
> gnome-dump.o: In function `main':
> gnome-dump.o(.text+0x43): undefined reference to `__db185_open'
> collect2: ld returned 1 exit status
> make[2]: *** [gnome-dump-metadata] Error 1
> make[2]: Leaving directory `/usr/local/src/gnome-libs-1.2.8/libgnome'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/usr/local/src/gnome-libs-1.2.8'
> make: *** [all-recursive-am] Error 2
>
> I don't know what's wrong, db installed without a problem.
>
> --
> Arnout
>
> --
> Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
> and put unsubscribe in the subject header of the message
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: gnome-install.txt
URL: <http://lists.linuxfromscratch.org/pipermail/blfs-support/attachments/20001128/e2166b79/attachment.txt>


More information about the blfs-support mailing list