can't open pseudo-term?

Arnout Couperus llhorian at chello.nl
Mon Nov 27 13:48:31 PST 2000


Well I've added the line to /etc/fstab, I added the /dev/ptmx and I even reinstalled aterm to be certain...
Now it says 
aterm: can't open slave tty (null)

It's a change, I'll give you that :)

--
Arnout

And on the day of Mon, Nov 27, 2000 at 07:25:46PM +0000, Ainsley Pereira was heard defying the gods with the words:
> In message <20001126220443.A767 at taranis.arnhem.chello.nl>
>           llhorian at chello.nl (Arnout Couperus) wrote:
> 
> > What, pray tell, is a pseudo-term and why won't it open?
> 
> Things to check/try:
> 1. Unix98 PTY's enabled in your kernel config
> 2. /dev/pts mounted (line like:
> none /dev/pts devpts gid=5,mode=620 0 0
> in /etc/fstab should do it)
> 
> There's also the possibility that configure picked up a wrong setting - this happened to me with screen, and was fixed with a little hacking.
> 
> I'd tell you what a pty is, only I've just seen the time. Read the help on the unix98 pty option in the kernel config:)
> 
> ~A.
> 
> -- 
>  -----------------------------------------------------------
>    / Ainsley Pereira       /   aka Marble on Snowplains   /
>   /                       / telnet://snowplains.org:3456 /
>  ------------------------------------------------------------
> 
> -- 
> Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
> and put unsubscribe in the subject header of the message
> 

-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list