upgrading the kernel

Gerard Beekmans gerard at linuxfromscratch.org
Tue Nov 21 04:57:26 PST 2000


> I installed LFS with the 2.3.51 kernel, upgraded to 2.4test10 with no
> problems. Some things may need to be recompiled if you're upgrading from
> 2.2 - ppp is the only one that comes to mind - that has some differences
> depending on which kernel you're using. There are probably other things,
> but I don't know of any.
>
> As for stability, I have no problems, with the kernel, although as a home
> system, my machine doesn't run for long without rebooting anyway. Looking
> forward to the official 2.4 release.

When I went from 2.2 to 2.4-test8 I had to recompile the ppp package as well 
as the ifconfig utility (it made Linux freeze up). I can't remember if there 
were others because I just recompiled both the netkit-base and the net-tools 
packages. I haven't had any experiences yet.


-- 
Gerard Beekmans
www.linuxfromscratch.org

-*- If Linux doesn't have the solution, you have the wrong problem -*-

-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list