X 4.0.1

Seth Payne SPayne at Legato.com
Mon Nov 13 09:43:42 PST 2000


Ok, when I try to startx I get an error saying:

cannot open device /dev/mouse

but I also get the error if I have indicated /dev/psaux as my mouse in the
XF86config file.

is this because permissions are not correct?

-----Original Message-----
From: Dennis Leeuw [mailto:dleeuw at made-it.com]
Sent: Monday, November 13, 2000 10:15 AM
To: lfs-apps at linuxfromscratch.org
Subject: Re: X 4.0.1


Oeps, ... you say busmouse?
Do you really mean busmouse?????? That means a NINE PIN MINI-DIN
CONNECTOR??????
Probably not, I guess you mean ps/2 a 6-pin mini-DIN connector that is used
on almost every keyboard now, correct?

Well, if that is the case make sure /dev/mouse is a symlink to /dev/psaux or
set your mouse in XF86config to /dev/psaux and make
sure to select the protocol needed for your mouse (atleast that's it in
XFree86 3.x.x that I am using).

Greetings,
Dennis


Robert Bercik wrote:

>         I am trying to install X 4.01 and I've got almost everything set
up... The problem is that everytime I start the
> Xserver it crashes and tells me my mouse device is not configured. I ran
MAKDEV busmice and it created a couple mouse devices
> and what not and I changed my XF86Config file to point to the appropriate
devices. But startx still crashes with the error
> about the mouse and something about core-pointers to my mouse and
keyboard. Anyone know why this is happening or how to
> manually configure my /dev/mouse device file? All input is appreciated.
> Thanks
>
> -Rob



>
>
> --
> Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
> and put unsubscribe in the subject header of the message

-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list