static perl?

fred anger anger at rightarm.org
Tue Nov 7 19:55:46 PST 2000


Hi all.  I'd like to automate the chroot'ed part of a custom LFS-based
install using a perl script (already did the static part that way, and I'm
quite fond of it ;)

Of course, this requires that perl be installed during the static part (or
soon thereafter).  I've attempted a couple approaches in the last few
hours, but thought I'd plug the list (thanks Reaperx1) before pursuing one
of them further.

First approach was to install perl right after chroot'ing.  No dice,
perl's Configure needs awk.  Tried installing mawk first, still no dice,
the Makefile wasn't getting written out correctly (missing line seperator
errors).

Second approach was to attempt to build a static perl during the static
part.  Here's the configure line I used (in $LFS/usr/src/perl-5.6.0):

../Configure -Dprefix=../../ -Uusedl -Uinstallusrbinperl -de

This configured, compiled, tested (1 failed), and installed ok, but after
chroot-ing and running perl, I get this error:

bash-2.04# perl
perl: error in loading shared libraries: libgdbm.so.2: cannot open shared
object file: No such file or directory

Reaperx1 suggested copying that library from my system, which I did, but
then got:

bash-2.04# perl
perl: /lib/libc.so.6: version `GLIBC_2.2' not found (required by perl)

This would be because I'm on Redhat 7 :(

Any suggestions?

BTW:  There's a patch for gcc that allows you to build it on glibc-2.2
systems at: http://gcc.gnu.org/ml/gcc-patches/2000-11/msg00040.html :)

-fa




-- 
Unsubscribe: send email to lfs-apps-request at linuxfromscratch.org
and put unsubscribe in the subject header of the message




More information about the blfs-support mailing list