[blfs-dev] My BLFS checks

Fernando de Oliveira famobr at yahoo.com.br
Tue Mar 25 10:15:25 PDT 2014


Em 18-02-2014 15:47, Armin K. escreveu:
> On 02/18/2014 06:29 PM, Armin K. wrote:


>> All packages were run with testsuites (yeah, I can't believe it either),
>> so I had to build a bit more packages than I actually needed. I still
>> can't get glib testsuite to finish ... It has been running for half an
>> hour yet. If it finishes, I'll post the result.


>> If the glib manages to complete today, I'll post it too.
>>
> 
> "make check" was running for 90 minutes and I canceled it. If anyone
> manages to get it to work, please let me know. Most of the time it spent
> idling on the same test - gio one, not sure exactly which is it.

Sorry, for the delay. The tests were on the older dev machine, never
remembered to get them, when BLFS-7.5 was not running for development.

But at the results below are for the new version glib-2.40.0.


One test failed: test_timer_basic

$ cat glib-2.40.0/glib/tests/timer.log
**
GLib:ERROR:timer.c:38:test_timer_basic: assertion failed (micros ==
((guint64)(elapsed * 1e6)) % 1000000): (4 == 3)
../../tap-test: line 5: 18123 Aborted                 $1 -k --tap
# random seed: R02Sc07a858e6ba4295f80fbba24f840fdc7
# Start of timer tests
# GLib:ERROR:timer.c:38:test_timer_basic: assertion failed (micros ==
((guint64)(elapsed * 1e6)) % 1000000): (4 == 3)
ERROR: timer - missing test plan
ERROR: timer - exited with status 134 (terminated by signal 6?)

For the tests:

SBU: 3.4
Additional size: 54 MB

I have tried a patch from Debian, transformed in sed, so other places
were also modified, but the problem continues. I am not sure, but it
seems I had this problem before, don't remember in which version.

-- 
[]s,
Fernando



More information about the blfs-dev mailing list