[blfs-dev] PHP-5.5.10 error: 'tsrm_ls' undeclared [Was: ... #4813: SWIG 3.0.0]

Armin K. krejzi at email.com
Sat Mar 22 14:40:24 PDT 2014


On 03/22/2014 09:36 PM, Pierre Labastie wrote:
> Le 22/03/2014 20:10, Pierre Labastie a écrit :
>> Le 22/03/2014 19:42, Fernando de Oliveira a écrit :
>>> Em 22-03-2014 14:57, Pierre Labastie escreveu:
>>>
>>>> Well, I am sorry to tell that the tests do not pass after building php with
>>>> the sed. There is also this thread:
>>>> http://sourceforge.net/p/swig/mailman/message/31802171/
>>>>
>>>> where a test case showing the exact same bug is reported, but it is said the
>>>> bug is fixed in 3.0.0
>>>
>>>
>>> I don't know if we are talking abaout the same thing, but fir me the
>>> "PHP-5.5.10 error: 'tsrm_ls' undeclared ..." is gone also in swig's test:
>>>
>>> $ grep -i tsrm
>>> /home/fernando/Downloads/blfs/swig-3.0.0-make-k-check-2014.03.22-14h48m07s.log
>>>
>>> gives me nothing. Actually, in the whole build it is not referenced:
>>>
>>> $ xzgrep tsrm
>>> /home/fernando/Downloads/blfs/swig-3.0.0-simulation-2014.03.22-14h48m07s.log.xz
>>>
>> I believe you. I must have done something wrong. Give me just some more time.
>>
>> Actually, what amazes me, is that applying the sed or not, php config.log does
>> not change...
>>
>> Let me try again: I am puzzled!
>>
>> Pierre
>>
> No errors in the test now: when I first tried, I built with the sed, but did
> not remove the previous, non-sed, build. Now I cleaned up everything and it works.
> 
> I make a ticket and assign it to myself. Will commit tomorrow if not tonight...
> regards
> Pierre
> 

Here's the thing:

Default MPM in httpd-2.4.x is threaded mpm, mpm_event. You can't use
non-ZTS PHP apache module with it. The solution is to use non-threaded
MPM which is awful (prefork or something like that) or use php-fpm via
mod_proxy_fcgid or php-cgi via mod_fcgid (separate package). I, for one,
use php-fpm.

-- 
Note: My last name is not Krejzi.



More information about the blfs-dev mailing list