[blfs-dev] PHP-5.5.10 error: 'tsrm_ls' undeclared [Was: ... #4813: SWIG 3.0.0]

Armin K. krejzi at email.com
Sat Mar 22 07:06:54 PDT 2014


On 03/22/2014 02:32 PM, Fernando de Oliveira wrote:
> Em 22-03-2014 08:48, BLFS Trac escreveu:
>> #4813: SWIG 3.0.0
>> -----------------------------+------------------------------
>>  Reporter:  pierre.labastie  |       Owner:  pierre.labastie
>>      Type:  enhancement      |      Status:  assigned
>>  Priority:  normal           |   Milestone:  7.6
>> Component:  BOOK             |     Version:  SVN
>>  Severity:  normal           |  Resolution:
>>  Keywords:                   |
>> -----------------------------+------------------------------
>>
>> Comment (by pierre.labastie):
>>
>>  All tests passed, except some with PHP: several tests have an issue with
>>  'tsrm_ls' undeclared, and I do not know whether it comes form our php
>>  build or from swig. This issue was also present in older versions.
> 
> I think the problem is php.
> 
> I have mentioned this error, building graphviz and asked for help.
> 
> Title "[blfs-dev] graphviz-2.36.0 and PHP-5.5.10"
> 
> http://permalink.gmane.org/gmane.linux.lfs.beyond.devel/26100
> 
> Em 19-03-2014 20:07, Fernando de Oliveira escreveu:
> 
>> ...
> 
>> Found references to this error, but no solution.
>>
>> I am worried, because recently I updated php, and it may be a problem in
>> the book.
>>
>> For my particular use, I am not worried.
>>
>> Please, somene confirm if this is a local or a general problem (in this
>> case, a solution would be muc welcomed).
> 
> ...
> 
>> gv_php_init.c: In function 'gv_string_writer':
>> /usr/include/php/Zend/../TSRM/TSRM.h:167:18: error: 'tsrm_ls' undeclared
>> (first use in this function)
>>  #define TSRMLS_C tsrm_ls
> 
> Thanks for confirming that it is a general problem.
> 
> I will investigate again, if cannot find a solution, will open a ticket.
> 
> 

Default php that's built against apache 2.4.x is thread safe php, also
known as ZTS which is kind of experimental feature. tsrm_ls is probably
wrapped and exported when ZTS is enabled and SWIG doesn't assume that
php is built with ZTS enabled. I wish I could help more, but I don't
know that much about php. Hope that I helped at least a bit.

-- 
Note: My last name is not Krejzi.



More information about the blfs-dev mailing list