[blfs-dev] what about gtk+3 in icedtea ?

Pierre Labastie pierre.labastie at neuf.fr
Thu Mar 20 03:32:55 PDT 2014


Le 20/03/2014 10:18, Fernando de Oliveira a écrit :
> Em 19-03-2014 19:08, Pierre Labastie escreveu:
>> Hi again,
>>
>> Now I see that gtk+3 is required, while configure tests explicitely for gtk+2...
>>
>> Is there something to be added so that it accepts gtk+3 (maybe in pkg-config
>> files or so)?
> This is interesting, never notice. It is there since its origin, r10274.
>
> While you are there and have enough time, I would much appreciate if you
> could fix the other question, this on now and others you find.
>
> Thanks.
>
Thanks, Fernando.
Actually, it is my first building of openjdk-icedtea (I need java for 
SWIG testing), so you are much more experienced than I am.

But I am really not sure about the gtk+{2,3} stuff. It is amazing that 
nobody (and particularly you, Fernando) has noticed that before, so I 
may be totally wrong. The only thing(s) I know is that I built only 
gtk+3, that configure tells it cannot find gtk, and that there is 
somewhere in configure:
---------
$PKG_CONFIG --exists --print-errors "gtk+-2.0 gthread-2.0"
---------
and no reference to gtk+-3.

OTOH, I see now that gtk+2.0 is a run-time dependency of the java 
binary, which means that:
(i) I should have built gtk+2
(ii) if gtk+2 is the only needed gtk for building openjdk, and the user 
is smarter than I, gtk+2 should be there when building icedtea, so no 
need to mention it (and neither gtk+3)...

Regards
Pierre




More information about the blfs-dev mailing list