[blfs-dev] Package Currency

Fernando de Oliveira famobr at yahoo.com.br
Thu Mar 13 13:16:58 PDT 2014


Em 13-03-2014 13:05, Bruce Dubbs escreveu:
> Thanks Fernando.  Comments below.  The issue is how to decide on what is 
> current for scripting purposes.  Some cases use even for development and 
> odd for stable (or maybe the opposite).
> 
>    -- Bruce
> 
> 
> Fernando de Oliveira wrote:
>>
>> Chapter 9
>> libsigc++	2.3.1	2.2.11	* book is good
>> http://ftp.gnome.org/pub/gnome/sources/libsigc++/2.3/libsigc++-2.3.1.tar.xz
> 
> Even only?

I think this does not follow odd/even

> 
>> Chapter 13
>> cmake	2.8.12.2	3.0.0-rc1	* (think we do not want rc1?)
>> http://www.cmake.org/files/v2.8/cmake-2.8.12.2.tar.gz
> 
> I left it that way because it is too complicated otherwise.  I first 
> have to determine highest directory, e.g, v3.0.  Then look in that 
> directory for max version.  In this case only rc values.  I'd have to 
> back up to next highest directory and again find teh highest value.  Too 
> much work for this one package.  When 3.0 is released, it will reflect 
> that correctly.  For now, we just leave it as a difference.

OK

> 
>> Chapters 14-16
>> wireshark	1.10.6	1.11.2	* (minor not odd)
>> https://www.wireshark.org/download/src/all-versions/wireshark-1.10.6.tar.bz2
> 
> Will update.
> 
>> Chapters 20-23
>> mariadb	10.0.8	5.5.36	* (you already know, just recalling)
>>
>> virtuoso	6.1.8	7.1.0	*
>> Modificado 26 horas atrás por rt

Sorry, only now, saw it was not in English: "Modified 26 hours ago by rt"

>> We may want to stay with Virtuoso 6, as it seems Virtuoso 7 requires 64-bit.
> 
> We need to decide.

I still need 32bit. Have only one LFS 7.3 64bit just for OJDK binary.

> 
>> Chapter 24
>> xf86-input-wacom	0.23.0	0.22.1	* book is good
>> http://sourceforge.net/projects/linuxwacom/files/xf86-input-wacom/
> 
> Wow do we know in the future.

Igor does. :-)

> 
>> Chapter 30
>> libpeas	1.9.0	1.8.1	* book is good
>> http://ftp.gnome.org/pub/gnome/sources/libpeas/1.9/libpeas-1.9.0.tar.xz
> 
> Even/odd?

I think this does not follow odd/even

> 
>> Chapters 32-33
>> midori	0.5.7	1.1	* book is good (at least, could not find 1.1)
>> http://www.midori-browser.org/downloads/midori_0.5.7_all_.tar.bz2
> 
> Let em get back to you on that.

This one, in the page

http://www.midori-browser.org/download/source/

has:

tar.bz2  ·  0.5.7  ·  1.1 MB

It seems the script is picking the size, not the version.

> 
>> Chapter 39
>> libass	0.11.1	0.10.2	* book is good
>> https://github.com/libass/libass/releases/download/0.11.1/libass-0.11.1.tar.xz
> 
> Even/odd?

I think this does not follow odd/even

> 
>> soundtouch	1.8.0	1.7.1	* book is good
>> http://www.surina.net/soundtouch/soundtouch-1.8.0.tar.gz
> 
> Even/odd?

I think this does not follow odd/even

Again, not completely sure about the comments.

-- 
[]s,
Fernando



More information about the blfs-dev mailing list