[blfs-dev] strigi-0.7.8 and clucene-2.3.3.4

Bruce Dubbs bruce.dubbs at gmail.com
Tue Mar 4 22:39:20 PST 2014


Ken Moffat wrote:
> On Thu, Feb 27, 2014 at 01:11:16AM -0500, Chris Staub wrote:
>> On 02/27/14 00:37, Bruce Dubbs wrote:
>>> I have a problem with the book's instructions building strigi.  clucene
>>> is listed as an optional dependency and I have that installed.  The book
>>> has
>>>
>>> cmake -DCMAKE_INSTALL_PREFIX=/usr \
>>>          -DCMAKE_INSTALL_LIBDIR=lib  \
>>>          -DCMAKE_BUILD_TYPE=Release  \
>>>          .. &&
>>>
>>> It gives a linking error with libclucene-core.so.  Something about
>>>
>>> undefined reference to symbol
>>> '_ZN6lucene4util14atomic_threads16atomic_decrementEPj'
>>> /usr/lib64/libclucene-shared.so.1: error adding symbols: DSO missing
>>> from command line
>>>
>>> Even though the symbol is in libclucene-core.so and it is specified when
>>> linking.
>>>
>>> I can only get it to build with
>>>
>>>        cmake -DCMAKE_INSTALL_PREFIX=/usr \
>>>              -DCMAKE_INSTALL_LIBDIR=lib  \
>>>              -DCMAKE_BUILD_TYPE=Release  \
>>>              -DENABLE_CLUCENE=OFF        \
>>>              -DENABLE_CLUCENE_NG=OFF     \
>>>              .. &&
>>>
>>> There is a reported error at http://sourceforge.net/p/strigi/bugs/114/
>>> but the comment there is:
>>>
>>> That CLucene version is not supported. We only support the stable
>>> CLucene version.
>>> The upcoming version is very different and needs quite some rewriting.
>>>
>>> The comment is October 2011, but is till marked
>>>
>>> Status: open-invalid
>>>
>>> whatever that means.
>>>
>>> Has anyone else seen this?
>>
>> I get the same error, and have the same options in my script for Strigi.
>>
>>>
>>    Should we remove the CLucene dependency and add the defines above?
>>>
>>>      -- Bruce
>   This appears to still be outstanding ?

Right.  We need to fix that.

   -- Bruce






More information about the blfs-dev mailing list