[blfs-dev] Upcoming BLFS-7.5 release

Ken Moffat zarniwhoop at ntlworld.com
Mon Mar 3 14:56:38 PST 2014


On Mon, Mar 03, 2014 at 06:30:21PM -0300, Fernando de Oliveira wrote:
> 
> Command Explanations
> ...
> --with-apache-libexecdir: If Apache-2.4.7 is installed, the shared
> Apache modules are built. This switch allows to have those modules
> installed to Apache's configured module dir instead of /usr/libexec. It
> has no effect if Apache is not installed.
> }}}
> 
> If I am understanding correctly, ĸen is talking about that difference,
> and that it would be good to have somewhere
> 
> --with-apache-libexecdir=$(/usr/bin/apxs -q libexecdir)
> 
 I'm sorry, this is another of my "brown paper bag" moments.  I did
not notice the *explanation* when I grepped for libexecdir
yesterday.  I did notice there was an explanation when I ran svn
update an hour or so ago.  I haven't actually looked at the page yet
(still sorting out what I intend to alter, and I had to go back to
my previous 'gnome' build in chroot because I also missed w3m, which
requires gc, yesterday), but that explanation you have posted above
looks good.  Again, my apologies.

 Thanks also to Pierre for his comments.

/me likes /usr/libexec, but not need for consequential changes to
the book at short notice.  I'll attempt to fix up the remaining
libexec stuff shortly - hopefully, *before* I ask myself "Do I feel
lucky ?", otherwise I might not do anything :-(

ĸen, a.k.a "why should I be right when I can easily be wrong ?"
-- 
das eine Mal als Tragödie, dieses Mal als Farce



More information about the blfs-dev mailing list