[blfs-dev] [BLFS Trac] #5155: xulrunner/firefox-30.0

Christopher Gregory me at pc-networking-services.com
Thu Jun 12 12:38:56 PDT 2014


On Fri, June 13, 2014 5:22 am, Armin K. wrote:
> On 06/12/2014 01:20 PM, BLFS Trac wrote:
>
>> #5155: xulrunner/firefox-30.0
>> -------------------------+-----------------------
>> Reporter:  fo           |       Owner:  fo
>> Type:  enhancement  |      Status:  assigned
>> Priority:  normal       |   Milestone:  7.6
>> Component:  BOOK         |     Version:  SVN
>> Severity:  normal       |  Resolution:
>> Keywords:               |
>> -------------------------+-----------------------
>>
>>
>> Comment (by Krejzi):
>>
>>
>> Thanks for the heads up Fernando. I will try building standalone
>> version of Firefox and see if it will solve my problem.
>>
>> FYI, this is the most recent bug report I have managed to stumble upon.
>> It
>> also affects Windows.
>>
>> https://bugzilla.mozilla.org/show_bug.cgi?id=1014214
>>
>>
>> If you have found some other, please say so that I could add my voice
>> to it :)
>>
>
> I just built Firefox-30.0 standalone and tabs are restored properly at
> startup. I even enabled system-cairo and it seems that all problems that I
> previously had with it are gone (mostly with flash player). However, I did
> notice that flash player will crash when gstreamer-vaapi is installed. I
> have no clue why would flash player try to use gstreamer but removing that
> package stopped flash player from crashing. Video isn't hardware
> accelerated but at least my laptop's temperature doesn't increase for
> 20°C when I play html5 video anymore.
>
>
> Also, instead of generating the installer and doing extract, there has
> been a change in build system that allows you do accomplish the same result
> with make install.
>
> Simply run "make -f client.mk install INSTALL_SDK=" (INSTALL_SDK=
> without any parameters, not a typo).
>
> I'd suggest enabling system-cairo for both thunderbird and firefox again
> since some people already said there should be no problems. Note that cairo
> needs --enable-tee switch by default and might need a patch pointed by a
> guy on one of lfs mailing lists.
>
> --
> Note: My last name is not Krejzi.
> --
> http://lists.linuxfromscratch.org/listinfo/blfs-dev
> FAQ: http://www.linuxfromscratch.org/blfs/faq.html
> Unsubscribe: See the above information page
>
>

Hello,

The patch IS needed for cairo if you use the --enable-xlib-xcb when
compiling system cairo.

The two of us that had that switch enabled resolved the frequent firefox
crashes by applying that patch.

Regards,

Christopher.




More information about the blfs-dev mailing list