[blfs-dev] ffmpeg-1.2.2 and libvpx-1.2.0

Bruce Dubbs bruce.dubbs at gmail.com
Thu Sep 26 19:18:34 PDT 2013


John Burrell wrote:
> The ffmpeg-1.2.2 configure, when applied as per the book, produces:
>
> ERROR: libvpx decoder version must be>=0.9.1
>
> This is because libvpx installs its headers in /usr/include/vpx with
> permission 640. Changing them to 644 solves the problem.
>
> It would be worth including a chmod at the end of the libvpx instructions.

I can't confirm that.  My vpx include files are all 664 and the 
directory is 755.  The log doesn't help because it doesn't give details. 
  I just did a quick DESTDIR install to /tmp and the permissions are OK.

Do you have a restrictive umask for root?

   -- Bruce






More information about the blfs-dev mailing list