[blfs-dev] [blfs-book] r11872 - in trunk/BOOK: x/lib xsoft/graphweb

Igor Živković contact at igor-zivkovic.from.hr
Wed Sep 25 13:28:58 PDT 2013


On 09/25/2013 09:09 PM, Ken Moffat wrote:
> On Wed, Sep 25, 2013 at 04:45:59AM -0700, igor at higgs.linuxfromscratch.org wrote:
>> Author: igor
>> Date: Wed Sep 25 04:45:59 2013
>> New Revision: 11872
>>
>> Log:
>> firefox actually requires the rtp plugin from gst-plugins-good package to play h264/mp4 videos
>>
>> Modified:
>>     trunk/BOOK/x/lib/xulrunner.xml
>>     trunk/BOOK/xsoft/graphweb/firefox.xml
>>
>> Modified: trunk/BOOK/x/lib/xulrunner.xml
>> ==============================================================================
>> --- trunk/BOOK/x/lib/xulrunner.xml	Wed Sep 25 02:40:02 2013	(r11871)
>> +++ trunk/BOOK/x/lib/xulrunner.xml	Wed Sep 25 04:45:59 2013	(r11872)
>> @@ -110,7 +110,7 @@
>>         <xref linkend="curl"/>,
>>         <xref linkend="dbus-glib"/>,
>>         <xref linkend="doxygen"/>,
>> -      <xref linkend="gst-plugins-base"/>,
>> +      <xref linkend="gst-plugins-good"/>,
>>         <ulink url="http://hunspell.sourceforge.net/">Hunspell</ulink>,
>>         <xref linkend="libnotify"/>,
>>         <xref linkend="startup-notification"/>,
>>
>   Do you know if the good plugins are needed at build time ?  Based
> on all the other packages using gstreamer which I have encountered,
> I assume that the base package is needed when building, and that
> firefox ought to run (without being able to play h264), so the good
> plugins would be a runtime recommendation ?
>
>   This sounds like splitting hairs, but I like to build firefox early
> on a new system.  There some optional deps for the good plugins that
> I usually build a lot later.

Only gstreamer-plugins-base package is required at build time. You can 
compile good-plugins-good at later time. That's what I did anyways when 
I discovered I can't view H.264 videos on my newest build.

-- 
Igor Živković
http://www.slashtime.net/



More information about the blfs-dev mailing list