[blfs-dev] Kde 4.11.1 can not find mime data

Bruce Dubbs bruce.dubbs at gmail.com
Tue Sep 17 13:09:27 PDT 2013


Magnus Larsson wrote:
> On 2013-09-17 21.05, Bruce Dubbs wrote:
>>
>> Lets start at the beginning.  Do you have:
>>
>> /usr/share/mime/application/octet-stream.xml
>> /usr/share/mime/inode/{directory,blockdevice,chardevice,socket,fifo}.xml
>> /usr/share/mime/application/x-*  etc
>>
>> If so, then try
>>
>> export XDG_DATA_DIRS=/opt/kde/share:/usr/share
>>
>>     -- Bruce
>>
>
> /usr/share/mime/application/octet-stream.xml
> Yes
>
> /usr/share/mime/inode/{directory,blockdevice,chardevice,socket,fifo}.xml
> Yes
>
> /usr/share/mime/application/x-*  etc
> Yes (many files)
>
> export XDG_DATA_DIRS=/opt/kde/share:/usr/share
> I still get the same error.
>
> 1: start console session as root user (no x server running, no kdm)
> 2: export XDG_DATA_DIRS=/opt/kde/share:/usr/share
> 3: start kdm from console

Why not just startx?  Is XDG_DATA_DIRS set properly when you bring up a 
terminal (e.g. konsole) in KDE?  I think you need to check if you are 
losing the environment when starting kdm.

You've got the files.  It's just a matter of getting KDE to find them.

Another thing to try:  Even if you get the messages, set
XDG_DATA_DIRS again in konsole and then launch konqueror  from the 
command line.

I'm not 100% sure the environment variable is XDG_DATA_DIRS, but trying 
different things from a konsole instance will help isolate what is 
happening.

Another idea, add a symlink:

ln -s /usr/share/mime /opt/kde/share/usr-mime

Not the right final solution, but it may give a clue.

   -- Bruce





More information about the blfs-dev mailing list