[blfs-dev] Kde 4.11.1 can not find mime data

Magnus Larsson k.magnus.larsson at tele2.se
Tue Sep 17 12:45:55 PDT 2013


On 2013-09-17 21.05, Bruce Dubbs wrote:
> 
> Lets start at the beginning.  Do you have:
> 
> /usr/share/mime/application/octet-stream.xml
> /usr/share/mime/inode/{directory,blockdevice,chardevice,socket,fifo}.xml
> /usr/share/mime/application/x-*  etc
> 
> If so, then try
> 
> export XDG_DATA_DIRS=/opt/kde/share:/usr/share
> 
>    -- Bruce
> 

/usr/share/mime/application/octet-stream.xml
Yes

/usr/share/mime/inode/{directory,blockdevice,chardevice,socket,fifo}.xml
Yes

/usr/share/mime/application/x-*  etc
Yes (many files)

export XDG_DATA_DIRS=/opt/kde/share:/usr/share
I still get the same error.

1: start console session as root user (no x server running, no kdm)
2: export XDG_DATA_DIRS=/opt/kde/share:/usr/share
3: start kdm from console

X server starts
I get kdm login window.
I log in as unprivileged user.
The kde progress bar shows on blue background "disk", "tools", "globe"
etc.
Then a kde session starts with a kickoff application launcher in the
left corner (K-menu). The desktop is black. I can launch Konqueror,
Dolphin etc, but all complain about mime, in the same way.

Then; Same error as before
pop up window stating:
-Error Run Command Interface
Could not find mime types:
"inode/directory"
<...similar...>
"application/x-desktop"

Magnus



More information about the blfs-dev mailing list