[blfs-dev] totem

Ken Moffat zarniwhoop at ntlworld.com
Tue Sep 10 07:48:25 PDT 2013


On Mon, Sep 09, 2013 at 05:45:03PM -0500, Bruce Dubbs wrote:
> There are only two packages left in the book that are marked at 7.3: 
> totem and seahorse.
> 
> I tried totem and got it to work, but it appears that the package 
> grillo, marked optional in the book, is really required.  From what I 
> can tell, this was true for 7.3 too.
> 
> The indication from running totem is that the grillo plugins are 
> required at runtime also.  The question at the moment is whether we 
> should archive totem or add grillo?
> 
 I found the same thing late last night after I'd built all the
required totem deps, except that I used a sed (based on an ubuntu
patch) to avoid grilo (proved that it would play local files), and
left a review of grilo until today.  I've just confirmed that the
change to require grilo is deliberate (I had wondered if it was
accidental, because the configure script still says that it will
skip over missing plugins) :

commit 3a1fead18a314bed420aa3692e39fbb8e9596889
Author: Bastien Nocera <hadess at hadess.net>
Date:   Fri Apr 13 16:14:14 2012 +0100


    build: Error out if some required plugins are missing

 That changed 'plugin_error_or_ignore' to 'plugin_error'.

 I haven't looked at grilo's dependencies, or its plugins (which
will enable more of the totem plugins), but my gut feeling is that
at least grilo needs to be in the book.

 I also noted that gentoo have it as optional, but they do that by
conditionally specifying which of the plugins to build (
--with-plugins= ) and hence omitting grilo plugins if grilo has not
been built.  That doesn't seem practical for BLFS.

 Rather than duplicate effort, I'll leave seahorse to you.

ĸen
-- 
das eine Mal als Tragödie, dieses Mal als Farce



More information about the blfs-dev mailing list