[blfs-dev] pango-1.34.0

Armin K. krejzi at email.com
Sat Mar 30 04:59:40 PDT 2013


On 03/30/2013 04:57 AM, Ken Moffat wrote:
>   I was looking at the (few) parts of gnome I still build, and
> assumed that I would want the latest pango (1.34.0).  Most of its
> dependencies are met by my most recent install, but it fails to
> configure becasue it can't find any suitable cairo font backends.
>
>   Digging down, this seems to be because it will only look for
> cairo-ft if a suitable version of fontconfig was installed.  And the
> suitable version is now >= 2.10.91.  The latest release of
> fontconfig is 2.10.2, although there is a later 2.10.92 development
> release.
>
>   For the little I'm hoping to build (basically, just gucharmap and
> evince with minimal dependencies and without introspection) I'll
> take a punt that I don't need pango-1.34.0.  So just a heads up for
> anyone who cares about gnome.
>
> ĸen
>

There's ticket in the trac for pango 1.32.6 which also needs unstable 
Fontconfig. Some libraries have been made thread safe, and need other 
thread safe libraries to work perfectly. In this case, first threadsafe 
version of Fontconfig was 2.10.91, Pango 1.32.6 ... Others were Gdk 
Pixbuf and librsvg iirc ...



More information about the blfs-dev mailing list