[blfs-dev] [blfs-book] [BLFS Trac] #3826: libreoffice-4.0.1.2

Fernando de Oliveira famobr at yahoo.com.br
Mon Mar 11 05:38:05 PDT 2013


--- Em dom, 10/3/13, Ken Moffat escreveu:

> De: Ken Moffat
> Assunto: Re: [blfs-dev] [blfs-book] [BLFS Trac] #3826: libreoffice-4.0.1.2
> Para: blfs-dev
> Data: Domingo, 10 de Março de 2013, 16:12
> On Sun, Mar 10, 2013 at 02:57:45PM
> -0000, BLFS Trac wrote:
> > #3826: libreoffice-4.0.1.2
> > 
> >  Procedure was the same for me. Only md5sum were
> changed. I didn't try
> >  building with system Boost, but now you confirm
> it's broken.
> > 
>  I've not long built 4.0.0.3, with system boost
> (1.53.0).  For
> liborcus I used a lo upstream patch, apparently it is
> faf72664d11deaa570a0f8c7e702ff07bf5914c8 (dunno if that is
> before or
> after 4.0.1.2 - the date of September 2001 is obviously
> bogus).
> For everything else I used a patch from gentoo (for some
> reason they
> think liborcus is worth building separately, so they don't
> the
> liborcus patch in lo).
> 
>  Attaching them, in case useful.
> 
> ĸen
> -- 
> das eine Mal als Tragödie, das andere Mal als Farce
> 

Thank you, ĸen.

It is well known this is not first libreoffice/boost problem. Armin 
has included a patch for a previous version.

LO downloaded boost 1_44_0, so this is what is being used by LO that 
Armin installs, IIUC.

I seem to be using boost just for LO, so perhaps will stick to older 
boost-1.51.0.

Fernando



More information about the blfs-dev mailing list