[blfs-dev] nvidia-313.18 fails to build on linux-3.8+; patch included

Fernando de Oliveira famobr at yahoo.com.br
Fri Mar 1 09:28:22 PST 2013


Failed to build the nvidia module for linux-3.8.1. Found in the web 
it fails for linux-3.8+.

Following patch has solved the problem:

# http://forums.gentoo.org/viewtopic-t-951692.html
# https://458382.bugs.gentoo.org/attachment.cgi?id=339464
--- a/kernel/conftest.sh
+++ b/kernel/conftest.sh
@@ -160,6 +160,7 @@ build_cflags() {

     if [ "$ARCH" = "i386" -o "$ARCH" = "x86_64" ]; then
         CFLAGS="$CFLAGS -I$SOURCES/arch/x86/include"
+        CFLAGS="$CFLAGS -I$SOURCES/arch/x86/include/uapi"
         CFLAGS="$CFLAGS -I$OUTPUT/arch/x86/include/generated"
         CFLAGS="$CFLAGS -I$OUTPUT/arch/x86/include/generated/uapi"
     elif [ "$ARCH" = "arm" ]; then

No idea how this problem and the vulnerability mentioned by Ken 
should be considered with respect to LFS7.3 release?

Just seen ticket "#3295: Linux-3.8.1" fixed, so, I believe no 
problem anymore with vulnerability.

[]s,
Fernando



More information about the blfs-dev mailing list