[blfs-dev] Does xterm work for UTF-8 ?

Ken Moffat zarniwhoop at ntlworld.com
Sun Feb 10 15:05:27 PST 2013


On Sun, Feb 10, 2013 at 02:53:31PM -0600, Randy McMurchy wrote:
> Ken Moffat wrote these words on 02/10/13 13:04 CST:
> > configure:14508: checking for usable Xft/fontconfig package
> > configure:14534: gcc -o conftest -g -O2  -D_GNU_SOURCE
> > -DNARROWPROTO=1 -DFUNCPROTO=15 -DOSMAJORVERSION=3 -DOSMINORVERSION=8
> > -I/usr/include/freetype2  conftest.c  -lXft   -lXmu -lXt -lX11
> > -lXaw7 -lXt -lX11   -lSM   -lICE   -lXt -lX11   -lncurses   >&5
> > /usr/bin/ld: /tmp/cc2otVoJ.o: undefined reference to symbol
> > 'FcPatternBuild'
> > /usr/bin/ld: note: 'FcPatternBuild' is defined in DSO
> > /usr/lib64/libfontconfig.so.1 so try adding it to the linker command
> > line
> > /usr/lib64/libfontconfig.so.1: could not read symbols: Invalid
> > operation
> > collect2: error: ld returned 1 exit status
> > 
> >  that results in configure reporting:
> > checking for usable Xft/fontconfig package... no
> 
> I have version 287 installed and have the exact same error in my configure
> logs.
> 
 Thanks.  If I manage to fix it, I'll commit the change.  At the
moment, using LIBS= and vanilla ./configure (with no options) seems
to work even on the version currently in the book, I just need to
find out which other setting prevents it compiling.

 Meanwhile, if you are using ttf fonts and have DejaVu but not
Bitstream-Vera I guess that most things will work if you are using a
UTF-8 locale - the only thing I've found so far, and which I can
actually key, is g with stroke [ used for one of the Sami languages
or orthographies, so not exactly common ].

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-dev mailing list