[blfs-dev] remove pcre from wireshark dependencies [Was: ... r12437 ]

Fernando de Oliveira famobr at yahoo.com.br
Thu Dec 26 04:30:30 PST 2013


Em 24-12-2013 10:32, Igor Živković escreveu:
> On 12/24/2013 12:45 PM, Fernando de Oliveira wrote:
>>
>> Before your post and due to Pierre's reply, I decided to do a last
>> investigation. Not sure if it concludes pcre should or not be
>> "Optional". All applications installed by wireshark-1.10.5 are linked to
>> pcre directly.
> 
> Not really. You're seeing libpcre.so in ldd output because 
> libglib-2.0.so links to it.
> 
> A better tool for such purposes is, for example, scanelf from pax-utils:
> 
> $ scanelf -BF "%f: %n" capinfos dftest dumpcap editcap mergecap  randpkt 
> rawshark reordercap text2pcap tshark wireshark
> 
> capinfos: 
> libwiretap.so.3,libwsutil.so.3,libgmodule-2.0.so.0,libglib-2.0.so.0,libgcrypt.so.11,libpthread.so.0,libc.so.6

...

This scanelf is very good, thanks.

-- 
[]s,
Fernando



More information about the blfs-dev mailing list