[blfs-dev] remove pcre from wireshark dependencies [Was: ... r12437 ]

Igor Živković contact at igor-zivkovic.from.hr
Tue Dec 24 02:09:12 PST 2013


On 12/24/2013 09:52 AM, Pierre Labastie wrote:
> Le 24/12/2013 03:29, Fernando de Oliveira a écrit :
>> Em 23-12-2013 22:30, Igor Živković escreveu:
>>> On 12/24/2013 12:52 AM, Fernando de Oliveira wrote:
>>>>
>>>> I hope you have seen the rest: there are many more places where it
>>>> appears. I put only a small part.
>>>
>>> According to their subversion repository history, it seems that PCRE was
>>> never used on Linux. It was used in Windows 32-bit build only:
>>>
>>> http://anonsvn.wireshark.org/viewvc?view=revision&revision=45035
>>>
>>> What is being used though is GRegex, see:
>>> https://developer.gnome.org/glib/2.37/glib-Perl-compatible-regular-expressions.html
>>>
>>
>> Thanks again, Igor,
>>
>> I am convinced by you, now. Thanks for your time to explain to me.
>>
> Does it mean that the wording should be:
> 'Required : GLib (with PCRE extension, to build the tty-mode front-end only)'?

No, GLib requires PCRE. The only choice with GLib is whether bundled or 
system-installed version will be used.

-- 
Igor Živković
http://www.slashtime.net/



More information about the blfs-dev mailing list