[blfs-dev] remove pcre from wireshark dependencies [Was: ... r12437 ]

Fernando de Oliveira famobr at yahoo.com.br
Mon Dec 23 18:26:42 PST 2013


Em 23-12-2013 20:44, Armin K. escreveu:
> On 23.12.2013 23:03, Pierre Labastie wrote:
>> Le 23/12/2013 22:05, Fernando de Oliveira a écrit :
>>> Em 23-12-2013 14:27, Igor Živković escreveu:
>>>> On 12/23/2013 05:20 PM, Fernando de Oliveira wrote:
>>>>> Em 23-12-2013 12:14, igor at higgs.linuxfromscratch.org escreveu:
>>>>>> Author: igor
>>>>>> Date: Mon Dec 23 07:14:25 2013
>>>>>> New Revision: 12437
>>>>>>
>>>>>> Log:
>>>>>> remove pcre from wireshark dependencies
>>>>>
>>>>> Did you remove because it is required by other dependencies? Please,
>>>>> tell which one. I am asking it because I need to improve (a lot) my
>>>>> knowledge about dependencies.
>>>>
>>>> I couldn't find in the source code where it's used directly. It might be
>>>> used via GLib though.
>>>>
>>>
>>> Thanks, Igor,
>>>
>>> I also could not find pcre at the beginning, but then I did:
>>>
>>> {{{
>>> $ find -iname \*pcre\*
>>> ./epan/ftypes/ftype-pcre.c
>>> $ grep -ri pcre
>>> ...
>>> }}}
>>>
>>> After that, I thought I should leave it as optional. So I was wrong,
>>> doing that, you think?
>>>
>> pcre is a required dep of GLib, which is a required dep of wireshark. I think
>> that's the reason why Igor removed it.
>>
>> Cheers
>> Pierre
>>
> 
> PCRE is recommended dep of Glib, and in the past we never used 
> recommended dependencies in dependency chain, only required ones.
> 

Thanks, Armin,

And it makes sense: only required can be assumed to be installed,
alternative reasoning to what you infer and to what I have written in a
previous post, agreeing with what you wrote above.

-- 
[]s,
Fernando



More information about the blfs-dev mailing list