[blfs-dev] libreoffice-4.1.1

Fernando de Oliveira famobr at yahoo.com.br
Sat Aug 31 04:27:16 PDT 2013


Em 30-08-2013 23:51, Fernando de Oliveira escreveu:
> Em 30-08-2013 22:20, Ken Moffat escreveu:
>> On Fri, Aug 30, 2013 at 10:07:07PM -0300, Fernando de Oliveira wrote:
> 
>>  There is now so much change in BLS that I don't always keep up to
>> date.  When I was first building LO-4.0 it failed for me because I
>> hadn't noticed that Python 3 was recommended and so I only had some
>> version of Python-2.7.  The error message made me think that Python 3
>> was required, at least for people who install languages ('en' has
>> historically been a bit special, not sure if requires any Python.)
>>
> 
> I misunderstood you, thought you wanted to avoid P3. I will have a
> carefull look at this issue, tomorrow.
> 

Finally understood. Of course, you are right, I am wrong (this is for
version in the book):

{{
$ xzgrep -i python
Downloads/blfs/libreoffice-4.1.0.4-build-2013.08.13-19h16m31s.log.xz
"/home/fernando/tmp/src-4.1.0.4/b3b2524f72409d919a4137826a870a8f-Python-3.3.0.tar.bz2"
-> "src/b3b2524f72409d919a4137826a870a8f-Python-3.3.0.tar.bz2"
"/home/fernando/tmp/src-4.1.0.4/bc702168a2af16869201dbe91e46ae48-LICENSE_Python-2.6.1"
-> "src/bc702168a2af16869201dbe91e46ae48-LICENSE_Python-2.6.1"
checking for a Python interpreter with version >= 2.5... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux3
checking for python script directory...
${prefix}/lib/python2.7/site-packages
checking for python extension module directory...
${exec_prefix}/lib/python2.7/site-packages
checking which Python to use for Pyuno... checking for a Python
interpreter with version >= 3.3... none
[build DEP] LNK:Library/libpythonloaderlo.so
[build CHK] python3
[build SLC] python3
[build SED] CustomTarget/pyuno/python_shell/os.sh
[build XCM]
officecfg/registry/data/org/openoffice/Office/Scripting-python.xcu
[build PKG] pyuno_python
[build CAT] CustomTarget/pyuno/python_shell/python.sh
[build PKG] scriptproviderforpython
[build PKG] scripting_ScriptsPython
[build UPK] b3b2524f72409d919a4137826a870a8f-Python-3.3.0.tar.bz2
[build CUS] pyuno/python_shell
[build PKG] python_shell
[build PAT] python3
[build SPP] scp2/source/python/file_python
[build SPP] scp2/source/python/file_python_librelogo
[build SPP] scp2/source/python/profileitem_python
[build SPP] scp2/source/python/module_python
[build SPP] scp2/source/python/module_python_librelogo
[build SCP] scp2/source/python/file_python
[build SCP] scp2/source/python/file_python_librelogo
[build SCP] scp2/source/python/profileitem_python
[build SCP] scp2/source/python/module_python
[build SCP] scp2/source/python/module_python_librelogo
[build INM] scp2/python
[build IMO] scp2/python
[build ALL] All packages: cli_ure_version.filelist ...

...


[build PRJ] python3
[build PKG] python3
[build EPK] python3
[build MOD] python3
[build LNK] Library/libpythonloaderlo.so
[build CMP] pyuno/source/loader/pythonloader
[build ALL] loaded modules: UnoControls accessibility afms ...
[build SLC] loaded modules: UnoControls accessibility afms ...
... installing module gid_Module_Script_Provider_For_Python ...
}}

I interpret this as: if there is no python3, it will build one, so,
better having it installed before. Cannot understand why they did not
use P2 for this.

>>  If you can get it to build without Python 3, and build the languages
>> (you build pt-BR which I assume should be enough to trigger the
>> problem) then all is well.
> 
> Me too.

Wrong was I.

>>  For the moment I'm still going to build the current version, and
>> all the raptors and rasqals and the things I tagged last week, to
>> make sure that they all still build on -rc2.

Again, perhaps you are telling me that I should leave the 3 Rs where
they are?

> I would not dislike, on the contrary, if you tried the new version and
> updated the book. Then, if you do not make the changes I proposed, I
> would do it afterwards.

I think I extrapolated here, apologies. Hope you understood what I said.

> With that, we would have double checked the
> package. And you would have the newer version, instead of having to
> build two versions.


-- 
[]s,
Fernando



More information about the blfs-dev mailing list