[blfs-dev] glibc errors in blfs packages on i686

Bruce Dubbs bruce.dubbs at gmail.com
Fri Aug 30 07:20:28 PDT 2013


Matt Burgess wrote:
> On Thu, 2013-08-29 at 17:22 +0100, Ken Moffat wrote:
>> On Thu, Aug 29, 2013 at 10:02:41AM -0500, Bruce Dubbs wrote:
>>>
>>> OK, I'll do a -rc2 today.  I think it best to slip the stable release to
>>> September 7.  Should we update to the newer gettext, kbd, and/or kmod at
>>> the same time?  Those all seem to have lower potential for problems than
>>> the glibc sed.

>>   I'm not in favour of updating anything except glibc.
>
> I tend to agree as well, just out of principle if anything else. It
> seems strange to declare a package freeze for the rc period and then not
> freeze the packages, no?  I'll admit that the upstream changes don't
> look too invasive, but there's always the risk of regressions.

OK, I just rebuilt LFS in my sandbox with the new packages.  It was 
extremely clean.  I had no FAILs at all and The only Errors were from glibc:

make[3]: *** [/sources/glibc-build/posix/tst-getaddrinfo4.out] Error 1
make[3]: [/sources/glibc-build/posix/annexc.out] Error 1 (ignored)
make[3]: [/sources/glibc-build/conform/run-conformtest.out] Error 1 
(ignored)

OTOH, I understand the concerns.  I'll revert what I did in my sandbox 
and rebuild and from that do -rc2.  I will still take the advice in 
Chapter 3:

"The Linux kernel is updated relatively often, many times due to 
discoveries of security vulnerabilities. The latest available 3.10.x 
kernel version should be used"

   -- Bruce



More information about the blfs-dev mailing list