[blfs-dev] libvdpau

Bruce Dubbs bruce.dubbs at gmail.com
Thu Aug 29 07:52:56 PDT 2013


Markku Pesonen wrote:
> Bruce Dubbs wrote:

>> I also found:
>>
>> http://lists.freedesktop.org/archives/xorg-announce/2009-September/001036.html
>>
>> where it says: To actually use a VDPAU device, you need
>> a vendor-specific implementation library.  Currently, this is always
>> libvdpau_nvidia.  You can override the driver name by setting the
>> VDPAU_DRIVER environment variable.
>>
>> My video is "NVIDIA Corporation NV37GL [Quadro PCI-E Series]", but it
>> does noot seem that libvdpau is doing anything for me.  Should this be
>> removed from the book?  Or, perhaps a note saying it is only useful in
>> conjunction with the proprietary nvidia drivers?
>
> I've successfully used mplayer+libvdpau+nouveau combination.
>
> When libvdpau is built before Mesa, you should get
> /usr/lib/vdpau/libvdpau_nouveau.so, which libvdpau should use instead of
> the default proprietary libvdpau_nvidia.so.
>
> Hardware video decoding is still work in progress for nouveau, see
> http://nouveau.freedesktop.org/wiki/ for details.

Indeed, when I went back and rebuilt Mesalib after libvdpau, the library 
libvdpau_nouveau.so was built.  I did need to set export 
VDPAU_DRIVER=nouveau to get it to be recognized.

However, I still got an error:

[vdpau] Error when calling vdp_device_create_x11: 23

The above may be because I am running mplayer over an ssh connection. 
Going directly to the system, the error is a little more serious:

MPlayer interrupted by signal 11 in module: decode video
- MPlayer crashed by bad usage of CPU/FPU/RAM.
   Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
   disassembly. Details in 
DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
   It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
   gcc version. If you think it's MPlayer's fault, please read
   DOCS/HTML/en/bugreports.html and follow the instructions there. We 
can't and
   won't help unless you provide this information when reporting a 
possible bug.
Inconsistency detected by ld.so: dl-close.c: 771: _dl_close: Assertion 
`map->l_init_called' failed!

I don't think this is an error in mplayer.  It may be a HW/driver issue 
though.

   -- Bruce



More information about the blfs-dev mailing list