[blfs-dev] cups-1.6.3 compile failure

Ken Moffat zarniwhoop at ntlworld.com
Fri Aug 23 14:31:41 PDT 2013


On Fri, Aug 23, 2013 at 09:14:37PM +0000, John Burrell wrote:
> I can't get cups to compile with gcc-4.8.1
> 
> The result is:
> 
> /bin/ld: /usr/lib64/gcc/x86_64-unknown-linux-gnu/4.8.1/../../../../lib64/crt1.o: relocation R_X86_64_32S against `__libc_csu_fini' can not be used when making a shared object; recompile with -fPIC
> /usr/lib64/gcc/x86_64-unknown-linux-gnu/4.8.1/../../../../lib64/crt1.o: could not read symbols: Bad value
> clang: error: linker command failed with exit code 1 (use -v to see invocation)
> make[1]: *** [ippserver] Error 1
> 
> I tried CFLAGS+="-fPIC" as it suggests above, but it makes no difference.
> 
> Any ideas?
> 
 No.  Worked for me (without libusb).

 I see you are using clang.  That is probably where the problem
lies.

 My log's only mention of ippserver are:
a - util.o
Making all in test...
Compiling ippserver.c...
Compiling ipptool.c...
Linking ippserver...
Linking ipptool...
Linking ipptool-static...
Making all in filter...
Compiling error.c...
 (that was built with make -j4, some of it might be out of order)

ĸen
-- 
das eine Mal als Tragödie, dieses Mal als Farce



More information about the blfs-dev mailing list