[blfs-dev] Two difficulties (one in all versions)

Fernando de Oliveira famobr at yahoo.com.br
Wed Aug 21 09:36:18 PDT 2013


Did not know if sending here, to lfs -dev or to blfs -support.

1. Happened with lfs-7.2,7.3 (both svn) and now with 7.4-rc1.

Long ago, I reported that each time I tried to chroot in LFS7.2 (LFS7.1
as host), after logout and umount, had to reboot the system, because I
could not get a terminal anymore (have a screen capture showing this,
now), and today, X died, in the host.

This has been reproduced, today, host LFS7.1, chroot in LFS7.4-rc1. I
believe, now I understood the reason. I have (in 7.1):

$ grep tty /etc/group
tty:x:4:

$ grep /dev/pts /etc/fstab
devpts         /dev/pts     devpts   gid=4,mode=620      0     0

But I was mounting and chrooting with gid 5, as per the book's instructions.

Now, I have changed both to gid 5, to conform with the new versions, and
the problem disappeared. Of course, had to change tape's gid to 4.

Please, *warn me*, if, changing these, I am going to have any trouble in
my old system.

2. Happened, perhaps with all versions.

Every time I try to create compressdoc with cat command, I obtain a
corrupted unusable script. Then, use vim, instead, and copy/paste.

Today, after the problem, just downloaded it from [1], after I saw, for
the first time, I confess, the suggestion in blfs to do this, alternatively.

Have produced a diff, in case anyone thinks this info is relevant.

-- 
[]s,
Fernando


[1] <http://anduin.linuxfromscratch.org/files/BLFS/svn/compressdoc>



More information about the blfs-dev mailing list