[blfs-dev] postfix and berkeleydb

Ken Moffat zarniwhoop at ntlworld.com
Sun Aug 18 08:00:46 PDT 2013


On Sun, Aug 18, 2013 at 12:18:09PM +0200, Armin K. wrote:
> On 08/18/2013 06:47 AM, Ken Moffat wrote:
> >  Trying to get a recent build to a state where _I_ think it is
> > worth booting (particularly fcron, mail, nfs, openssh),
> > postfix-2.10.1 failed to build:
> > 
> > dict_db.c: In function 'dict_db_open':
> > dict_db.c:705:2: error: #error "Unsupported Berkeley DB version"
> >  #error "Unsupported Berkeley DB version"
> > 
> >  This is with db-6.0.20.  Reverted to 5.3.21, which I had been
> > using on my previous build, and postfix buildt and installed.
> > 
> > ĸen
> > 
> 
> Have a simple fix
> 
> sed "s:DB_VERSION_MAJOR == 5:DB_VERSION_MAJOR == 6 || &:" -i
> src/util/dict_db.c

 Thanks. I'll be doing a fresh build soon-ish, will let you know the
result of this.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-dev mailing list