[blfs-dev] postfix and berkeleydb

Bruce Dubbs bruce.dubbs at gmail.com
Sun Aug 18 07:12:24 PDT 2013


Ken Moffat wrote:
>   Trying to get a recent build to a state where _I_ think it is
> worth booting (particularly fcron, mail, nfs, openssh),
> postfix-2.10.1 failed to build:
>
> dict_db.c: In function 'dict_db_open':
> dict_db.c:705:2: error: #error "Unsupported Berkeley DB version"
>   #error "Unsupported Berkeley DB version"

  sed -i -e "s/DB_VERSION_MAJOR == 5/DB_VERSION_MAJOR >= 5/" \
    src/util/dict_db.c

I ran into this about a month ago, but forgot to update the book.

   -- Bruce





More information about the blfs-dev mailing list