[blfs-dev] [blfs-support] Trouble building LibreOffice-4.1.0

Fernando de Oliveira famobr at yahoo.com.br
Tue Aug 13 23:16:33 PDT 2013


Em 13-08-2013 22:22, Fernando de Oliveira escreveu:
> Em 13-08-2013 21:59, Fernando de Oliveira escreveu:
>> Em 13-08-2013 21:44, Armin K. escreveu:
>>> On 08/14/2013 02:36 AM, Fernando de Oliveira wrote:
>>>
>>> [...]
>>>
>>>>
>>>> One minor thing: harfbuzz is in a switch but not in Recommended
>>>> dependencies.
>>>>
>>>
>>> But GTK+2 is, and GTK+2 requires Pango, which requires Harfbuzz (dep.
>>> chain).
>>>
>>
>> OK. In the system I have just installed LO, I have pango-1.30.1, but did
>> not have harfbuzz, and installed harfbuzz-0.9.19. The most recent
>> system, I have pango-1.32.5 and, confirming your reply, harfbuzz-0.9.16
>> is installed. So, apologies for that, I had not realized it was already
>> installed in one system.
>>
> 
> Hit the same problem in this newer machine that already had harfbuzz:
> 
> ...bin/unpack-sources: Permission denied
> 
> Now, using --with-lang="", passed that point.
> 


The book uses --with-lang="" , that explains why the bug has not been
hit by strict use of copy/paste.

But also we have:

{{
 --with-lang="en-US pt-BR": This switch sets what languages to support.
en-US is always needed. To list several languages, separate them with a
space. For all languages, use --with-lang=ALL
}}

The easiest fix would be deleting any support for non-US locales, but I
cannot believe anybody would agree with that, for this package, at least.

A fix different from installing the binary packages from the Document
Foundation would be great, to return to normal status.  If we cannot
find it, I see no alternative other than including instructions on how
to install those language packs.

-- 
[]s,
Fernando



More information about the blfs-dev mailing list