[blfs-dev] [blfs-support] Trouble building LibreOffice-4.1.0

Fernando de Oliveira famobr at yahoo.com.br
Tue Aug 13 17:36:37 PDT 2013


Em 05-08-2013 12:12, Wayne Blaszczyk escreveu:
> On 05/08/13 19:59, Ken Moffat wrote:
>> On Mon, Aug 05, 2013 at 06:57:24PM +1000, Wayne Blaszczyk wrote:
>>>
>>> I've narrowed down the issue.
>>> I was setting --with-lang="en-GB en-US" (which is what I had set with
>>> the previous version), this resulted in the above error. Even with just
>>> en-GB or en-US by itself causes the error. I could only resolve the
>>> issue by having this option set to an empty string.
>>> What is the implication of having --with-lang="" ?
>>>
>>  According to the Arch wiki, you will only have Afrikaans (assuming
>> that you manage to install at least one language pack), e.g. in the
>> help files and perhaps in the menus.
>>
>>  I assume that you have built Python-3 ?  In 4.0 it was needed for
>> the translations.
>>
>> ĸen
>>
> 
> Yes, Python-3 was built.

...

> 
> Reverting back to neon-0.29.6 overcomes this issue.
> 
> Wayne.
> 

Same --with-lang="pt-BR en-US" problem, today, system with neon-0.29.6.
It is a running system, not chroot. Tried as root, as me, always
"permission denied".

After reading this thread and noticing that ArchLinux use what you
(Wayne) did, I followed the same path.

For the locale support, followed a similar approach to AL, only with
deb, instead of rpm. The langpack and helppack for many locales are
found at [1]. Then, I extracted and installed with the instructions in
the attached script. After sending this, I will repeat the LO build, if
the problem repeats, will then install the language support in the other
LFS machines.

I think something should be done to correct this, if Wayne and I are not
alone.

One minor thing: harfbuzz is in a switch but not in Recommended
dependencies.

-- 
[]s,
Fernando

[1] http://download.documentfoundation.org/libreoffice/stable/4.1.0



More information about the blfs-dev mailing list