[blfs-dev] gnucash brokenness

Ken Moffat zarniwhoop at ntlworld.com
Tue Feb 28 17:02:20 PST 2012


On Tue, Feb 28, 2012 at 04:41:22PM -0800, Fernando de Oliveira wrote:
> 
> Thanks for this message, Ken.
> 
> Sorry if I seemed to refer to version 3.30.2.
> 
> After one post you sent mentioned gtkhtml-4 and that you used *webkit* for gnucash, I switched the last builds to use webkit-1.6.3, not gtkhtml.
> 
 If that's ok with you, it's fine with me.

> Last build with *gtkhtml* in "LFS 7.0 svn" used version 3.32.2, which built using (I think one post replying to you had this version, already):
> 
> 
>       patch -Np1 -i $SOURCEDIR/gtkhtml-3.32.2-const-instead-G_CONST_RETURN-patch &&
> 
> ./configure --prefix=$(pkg-config --variable=prefix ORBit-2.0) \
>             --libexecdir=$(pkg-config \
>                 --variable=prefix ORBit-2.0)/lib/gtkhtml \
>             --disable-gtk3 \
>             --disable-deprecated-warning-flags &&
> 
> make -j1  && # (cannot remember if by accident, I copied the "j1" from another script or if ite is really necessary)
> 
> make install
> 
> 
> I believe prefix and directories could be different.
> 
> I will try building GtkHTML-4.2.2 and make a test of building gnucash-2.4.10 with it, if you have not yet done and it broke.
> 
 I did try, which was why I then used the sed to get gtkhtml-3 to
build.  But that version of gnucash (with the fedora patches) didn't
run, so I doubt my results for all the stages of the build [ it was
without slib, so very different from what we now have ].

 I only ever had the versions of gtkhtml that were in the book.
Actually, my *first* attempt to build it used a sed to change
G_CONST_RETURN to const, but then fell over with other deprecated
messages.

 Seems to me that we should just make webkit-1 required.  Thanks for
your input.

ĸen
-- 
das eine Mal als Tragödie, das andere Mal als Farce



More information about the blfs-dev mailing list