[blfs-dev] Apache-2.4.1 needs a sytem Apr and Apr-util

Andrew Benton b3nton at gmail.com
Tue Feb 28 16:38:07 PST 2012


Hello,
I've just been having a look at Apache-2.4.1.
Although ./configure --help says:
   --with-included-apr     Use bundled copies of APR/APR-Util
However, when I try to configure it --with-included-apr I get:

Configuring Apache Portable Runtime library ...

configure: error: Bundled APR requested but not found at ./srclib/. Download and unpack the corresponding apr and apr-util packages to ./srclib/.
andy at eccles:~$ 

So it seems that we either need to download them on the Apache page or
add them to the book as separate pages and make apr a required
dependency. Apr probably should be in the book as it's a required dep
of Subversion. Anyone have any thoughts on this issue? Any volunteers
to do the work ;)
Thoughts? Suggestions?

Andy



More information about the blfs-dev mailing list