[blfs-dev] gnucash brokenness

Andrew Benton b3nton at gmail.com
Sat Feb 25 09:14:32 PST 2012


On Sat, 25 Feb 2012 10:16:50 -0600
Bruce Dubbs <bruce.dubbs at gmail.com> wrote:

> > For me it is easy to keep guile-1.8.8 as I believe, I use it just for
> > gnucash.
> 
> Perhaps this is a case for a static library.

It's the guile command that fails trying to build a catalog of the slib
files. This is a scheme (Lisp) library, text files with lisp code in
them. If it was just c or c++ it wouldn't be so bad but this rubbish
smells like latex/texlive to me. This is an ex parrot. It has ceased to
be...

In the book I see guile mentioned on the gnucash and slib pages
(obviously) as well as the pages for: gnutls,  aisleriot, gnome-games,
gconf1, autogen and graphviz so reverting to guile-1.8.8 would have
implications to those other packages. The only one of those I install
is gnutls and it seems quite happy without guile.

Reverting to guile-1.8.8 is the only way I can see of fixing gnucash.
Personally I'm happy with gnucash and slib out of the book ;)
Anybody else want gnucash, slib and guile-1.8.8?

Andy



More information about the blfs-dev mailing list